Dimensional Chest Bug

Saturday (2/20) I was using my dimensional chests and had 5 of them in my inventory. I used 1 and all 5 disappeared. I didn’t think much of it maybe it was a one time occurrence, well I just did it again today and same result happened. I had 3 dim chest in my inventory and used 1 and all of them disappeared.

I’m now starting to wonder how often this is actually happening and I’m just not paying much attention to it.

Currently I have 1 character that is collecting them, 150+, and I would HATE to see them all vanish when I eventually use them.

This is the first I’ve heard of it happening, wait until after the restart to use them to feel safe.

It’s still happening. I had yesterdays and todays dim chests saved up (10 of them) and when i went to use 1 they all vanished… ughhhhhhhhhhhhhhhhhhhhhhhhh!!!

I’m looking into it now.

Okay, Somehow a delete Item packet is being sent with the double click of the inventory item by the client for some people when they are entering the dim chest. It seems very isolated as its not a lot of people that it has happened to. I’ve pulled a list of every single dim chest that has been deleted (whether by accident or by this potential bug) and I’ve restored these items to the characters. Here is a list of all characters who received dim chests and how many they received:

LittleNublet 1
Atilian 2
Frosty 6
Swashbuckler 30
Ork 4
Stardeep 5
Marv 4
Allison 13
Medic 6
Wizzerd 5
Listerine 2

I will continue to look further into this to see if its a bug with the client or the server and if you or anyone else notices their dim chests going missing, let me know so I can check the logs and restore them.

I had it happen again today.

Yeah I see it happened again on your alt and only 1 chest was removed.

This is really weird as the packet for delete should only ever be called by hitting the delete key or dragging an item to the trash can.

Its also weird that this only happens for this chest. See if you can track down something different you’re doing when this happens, compared to when it doesn’t. I’ll make sure to replace any lost chests to this bug.

EDIT: Also after the next restart, I’ll have a fix that should make sure it doesn’t happen again. Not really a fix so much as a work around. I’ve changed it so the item is un-deleteable.

the only thing i can think of is when i delete a bunch of stuff from my inventory and use dim chests they can get deleted upon using them. i tried it on another character right after this happened and didn’t delete anything prior to using dim chests and they didn’t disappear.

when you delete items do you use the delete key or drag to the trashcan?

It all depends, a lot of things can not be deleted with the delete key and need to be dragged and visa versa. I typically use the trash can after doing all my instances unless I need to do the delete key


Items are getting deleted again after an instance is completed.

If I’m in an instances waiting to get booted out and have items selected in my inventory at the time of being booted out those items will get deleted with out any prompts to delete.

I was arranging my inventory beteeen instances and deleted all the stuff I got from the Wedding Instance…granted it was only batteries and weak.

I’ve tried to repeat this bug and have been successful almost every time. (Just doing it with those damn flowers now)

I’ve heard of some other players with missing items - maybe this is the cause @JDZ

1 Like


I was thinking the same thing man. I mentioned this to zaj but he said no, that it was me intentionally shift clicking and deleting. I really hope this doesnt keep happening. Who knows what all ive really lost, i only notice when an expensive item is missing. Like my lvl 30 +7 zelin =\

1 Like

I don’t know if it’s the instance, but I’ve lost whole set of items when the log in and out time duration is short, and during that time played an instance. Granted that I was practically falling asleep during the short time, I might have accidentally deleted everything I got while organizing the character’s inven. I think it could be going in and out of an instance + log time being short.
Zaj lol I know your are busy, but if you find a zenith ring that’s been deleted, it’s Astos’s ring.

I have had pots, beads, crystals of protection and some other things disappear from inventory. The commonality appears to be that they were the last item I had selected/viewed from inventory and most of the times it seemed to happen after I used one of the commands preceded with a - (-doll, -weapon, etc). I did not realize it at first but once I got a message that said you cannot delete that item after I used one of those commands. Not sure if that is what’s really causing it but it seems to be a pattern that I have observed.

I think you might be on to something. I got the ring as a drop and had it clicked (strong possibility, I can’t say for sure though), before doing an instance, and then dim chest, all the while camped in toi 10. I think players should put items they got from before or during instance, in storage before logging off the first time after getting the said item, just to be on the safe side. Been losing dolls, consumables, etc.

This doesn’t explain how someone lost a good sword though…must be a different problem from the instance delete bug.

I think many of us organize our inven while waiting to be transported back. Perhaps, players should close inven window after finishing an instance.

Hmm, I’ll look into this with the new information provided.

Here’s another inventory bug. I had 64 pumpkin seeds, clicked on one and they all disappeared. Either the total was wrong or all were consumed at same time.

When it boots you out, the only thing it does is teleport you. When people report items missing, I’m getting actual Item Deleted messages in my logs, which only happens when the client sends a delete packet.

If you can chat with me about this in Discord and help me duplicate this bug, I can find a way to patch it out.


This morning at 4:02 eastern time, I clicked on my vit cube to sse if it were time for the prize. I then went to see how much aa I had. As soon as I typed the “-” I got the message “This item can’t be dropped or deleted”. Didn’t even have to hit enter. Popped up as soon as I typed the dash in the command line.

[Edit] - Forgot to mention that I had my inventory window open and the cube was highlighted. Also, was doing the Mayasura quest at the time. Not sure if this matters.